Service Issue Reported – ***New EDS UI***
Incident Report for EBSCO
Resolved
This incident has been resolved.
Posted Dec 11, 2024 - 20:15 UTC
Update
We are continuing to investigate this issue.
Posted Dec 11, 2024 - 19:31 UTC
Investigating
We have received reports of an issue with **New UI- Links/Custom Links not working ***. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Dec 11, 2024 - 19:30 UTC
This incident affected: EBSCO - New UI.