Service Issue Reported – BiblioGraph
Incident Report for EBSCO
Resolved
This incident has been resolved.
Posted Apr 19, 2024 - 17:06 UTC
Investigating
We have received reports of an issue with BiblioGraph. Our engineering teams are currently investigating the issue and we will update this page when more information is available.
Posted Apr 19, 2024 - 16:01 UTC
This incident affected: BiblioGraph.